股票 股票知识

显示 收起

通达信dmi指标公式 精典之极的公式源码介绍

对于每个散户来说,要想在股市中得到自己想要的东西(盈利),首先要不断学习,不断增强自身的炒股知识和技巧。今天我们一起来了解清楚dmi指标相关问题,比如:通达信dmi指标公式是什么?下面为大家带来精典之极的dmi指标公式源码介绍

通达信dmi指标公式

DMI指标又叫动向指标或趋向指标,其全称叫“Directional Movement Index,简称DMI”,也是由美国技术分析大师威尔斯·威尔德(Wells Wilder)所创造的,是一种中长期股市技术分析(Technical Analysis)方法。

DMI指标是通过分析股票价格在涨跌过程中买卖双方力量均衡点的变化情况,即多空双方的力量的变化受价格波动的影响而发生由均衡到失衡的循环过程,从而提供对趋势判断依据的一种技术指标。

dmi指标分类:DMI指标共有+DI(即PDI,下同)、-DI(即MDI,下同)、ADX、ADXR四条线,也是它的四个参数值,它分为多空指标(+DI、-DI)和趋向指标(ADX、ADXR)两组指标。

通达信dmi指标公式源码

TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-ref(CLOSE,1))),ABS(ref(CLOSE,1)-LOW)),N);

HD:=HIGH-ref(HIGH,1);

LD:=ref(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD0&&HDLD,HD,0),N);

DMM:=EXPMEMA(IF(LD0&&LDHD,LD,0),N);

PDI:=DMP*100/TR,COLORFFFFFF;

DRAWTEXT_FIX(CO,0.01,0.9,0''),COLORRED;

DRAWTEXT_FIX(CO,1,1,0,''),COLORRED;

MDI:=DMM*100/TR,COLOR00FFFF;

ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLOR0000FF,LINETHICK2;

ADXR:=EXPMEMA(ADX,M),COLOR00FF00,LINETHICK2;

DYNAINFO(9)0 AND CROSS(ADX,MDI) AND CROSS(ADXR,MDI) AND PDIMDI;

点击展开全文
推荐信息 理财项目投资专区,天天可提现分红!7.2万阅读
精彩图文